LOGISIM GIRiS

Logisim sayisal mantik devrelerini tasarlamak ve simiile etmek i¢in egitimsel bir aractir. Basit arag
cubugu arayiizii ve insa ettiginiz devrelerin simiilasyonu ile, mantik devrelerine bagli en temel
kavramlar1 6grenmeyi kolaylastirmak i¢in yeterince basittir. Kiigiik alt devrelerden biiylik devreler
inga etme ve tek bir fare siiriiklemesi ile kablo paketleri ¢izme yetenegi ile Logisim, egitimsel
amaglar i¢in tiim CPU' lar1 tasarlamak ve simiile etmek i¢in kullanilabilir (ve kullanilmaktadir).

Logisim, bilgisayar bilimi arastirmasinin genel egitiminde mantik iizerine 6zet bir liniteden
baslayarak bilgisayar organizasyon kurslarina, bilgisayar mimarisi iizerine tam donem kurslarina
kadar bir ¢ok ¢esit derste diinya ¢apinda kolejlerde ve iiniversitelerde 6grenciler tarafindan
kullanilmaktadir.
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Ozellikler

0 Bedavadir! (Logisim agik-kaynak kodludur -GPL.)

0 Java 1.4 yada daha iist destekleyen herhangi bir makinede ¢alisir; MacOS X ve Windows
icin 0zel versiyonlar giincellendi. Capraz-platform dogasi, ev/yatakhane bilgisayar
sistemlerinin bir tiiriine sahip 6grenciler i¢in dnemlidir.

0 Cizim arayliizii bir sezgisel ara¢ gubuguna baglidir. Renk-kodlu kablolar bir devreyi simiile
ederken ve hatasini ayiklarken yardimei olur.

0 Kablolama araci bilesenlere ve diger kablolara otomatik olarak baglanan yatak ve dikey
kablolar ¢izer. Devreleri ¢izmek ¢ok kolaydir!

0 Tamamlanmig devreler bir dosyaya kaydedilebilir, bir GIF dosyasina doniistiiriilebilir veya
yazicidan yazdirilabilir.

0 Devre planlar1 diger devrelerin "alt devreleri" olarak kullanilabilir, hiyerarsik devre
tasarimina izin verir.

0 Dahil edilmis devre bilesenleri giris ve ¢ikislari, gecitleri, ¢oklayicilari, aritmetik devreleri,
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iki duraklilar1 ve RAM hafizasini igerir.
0 Dabhil edilmis "kombinasyonel analiz" modiilii, devreler, dogruluk tablolar1 ve Boole
ifadeleri arasinda doniisiime izin verir.

Yeni Baslayanlar i¢in Kilavuz
Oncelikle Logisim'in son siiriimiinii indiriniz. Kurmaniza gerek yoktur, direkt olarak calistirm.

Arayiiz tamitimim1 yaptiktan sonra bir 6rnekle simiilatdriimiizii daha iyi tantyacagiz. Oncelikle iist
kisayol kullanim satirini inceleyelim;

[1k olarak “OK simgesini” ele alalim. Kablo ya da diger bir deyisle devre elemanlarini baglarken ki
¢izimlerimizde bu butonun aktif olmas1 gerekmektedir. ( Sekil-1 )
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+ Kirmim cember iginde gosterilen simge gizimlerde aletif <
7 United olmalidir. Yoksa gizin gergeklestinilemez.
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Circuit Mame main

Shared La... [East
Shared La... [SansSerif ...

Sekil-1
Ardindan birka¢ kapinin kisayolu gene ayni satir lizerinde bulunmaktadir. Bu kapilar Gates
kisminda da bulunsa da ¢ok kullanildiklari i¢in yukardaki satir da bulunmaktadir. ( Sekil-2 )
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Sekil-2

Diger iist satir kisa yolumuz Pin'lerdir. {1k olarak Giris Pin'inin gdsterelim. Giris Pin'i
devrelerimizin girisleri yani inputlari i¢in kullanilir. Her giris i¢in bir Pin kullanilmadar. ( Sekil-3 )
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Diger Pin ise ¢ikis Pin'idir. Cikis yani output devredeki her ¢ikis i¢in kullanilmadir. ( Sekil-4 )
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Sekil-4

Ust satirdaki simgelerimizden biri olan yazi i¢in kullanilan “A” simgesidir. Devreyi daha anlasilir
kilmak i¢in isimlendirme yapmamizi saglar. ( Sekil-5 )
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Sekil-5

Ust satirdaki son simge el simgesidir. Input degerlerini elle vermemiz gereken devreler oldugunda

Ya da clock pulse'ini elle vermemiz gereken durumlarda aktif olmas1 gereken birimdir. ( Sekil-6 )
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Sekil-6
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Logisim simiile programinda altta yesil bir arti mevcuttur. Bu isaret bize alt devre yapmamizda
yardimei1 olan bir kisayoldur. ( Sekil-7)
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Sekil-7

Bu yesil art1 simgesine tikladigimizda ontimiize kiigiik bir kutucuk gelir. Bu kutucuk bizden alt
devremize isim vermemizi ister. ismi verip “OK” 'a basmaliy1z. ( Sekil-8 )
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Sekil-8

Sol meniileri de kisaca tantyalim ( Sekil-9 ve Sekil-10 ):

Untitled; Devrenin ismi burada goziikiir.

Wiring; Tiirk¢esi kablolama olarak gecer. Igersinde pin, clock, resistor gibi devre elemanlarmi
barindirir.

Gates; Bilgisayarin temelini olusturan kapi devrelerini igersinde barindirir.

Plexers; Igerisinde multiplexer, demultiplexer, decoder gibi devreleri barmndirir.

Aritmetic; Aritmetik islemler i¢in gerekli birimleri i¢inde barindirir.

Memory; RAM, ROM, FF gibi hafiza birimlerini i¢inde barindirir.

Input/Output; Button, led, joystick gibi I/O islem birimlerini i¢inde barindirir.
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-+ Kabilglaima, icerinde pin, clock, resistor gibi devré galismalarinda kullanilacak yapilae vardic.
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'RAM, ROM,; Flip: Flop gibi hafiza birimlerinin bulundugu:yerdir.

Sekil-9
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Sekil-10

Logisim simiile programinin daha iyi anlagilabilmesi i¢in XOR mantiksal devresini asama asama
gerceklestirelim. XOR problemi i¢in dogruluk tablomuz su sekildedir: ( Sekil-11)
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Sekil-11
Ve simiile edilmesi gereken devresi asagidaki gibidir: ( Sekil-12)

e

x XOR v

Bu bilgiler 1s181nda logisimde ¢izimimize baslayabiliriz.

Sekil-12

I1k olarak bize lazim olan 2 adet 2 girisli AND kapisidir. Bunu elde etmek igin iist satir kisayollarini
ya da sol taraftan Gatesden AND kapisini segerek yapabiliriz ( Sekil-13 )
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Sekil-13

Burada dikkat edilmesi gereken dnemli bir husus sectigimiz kapilar 5 girisli gelmektedir. Sol tarafta
number of inputs'dan 5 olan girisi 2 yapmaliy1z. ( Sekil-14)
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Sekil-14

AND kapilarimizdan birini elde ettik. Ikincisini de ayni sekilde elde edebilir veya direkt olarak 2
girisli olmasi i¢in kopyala yapistir ile ikinci kapimizida elde etmis oluyoruz. ( Sekil-15)
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XOR problemi i¢in bize disardan iki giris gerekmektedir. Bu baglamda Pin'lerle giriglerimizi
konumlandirtyoruz. ( Sekil-16)
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Sekil-16

Devre elemanlar1 arasinda baglantiy1 (Kablo) saglamak i¢in Pin'in ¢ikisa imleci gotiiriip farenin sag
butonuna basili tutup ¢ekip hizali bir sekilde AND kapisinin girisine kadar getiriyoruz. ( Sekil-17)
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Birer girisleri Pin'lerle yapilmis olan AND kapilarinin diger girisleri ¢apraz sekilde NOT yapist ile
veriyoruz. NOT kapisini iist satir kisayollardan ya da soldan Gatesden alabiliriz. ( Sekil-18)
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Sekil-18
AND kapilarinin ¢ikiglarint alip OR kapisinin girislerine veriyoruz. Burada da dikkat edilmelidir.
Gates ya da kisayollardan kapiy1 aldiktan 5 girisli olacaktir. Bu say1 2 yapilmalidir. ( Sekil-19 )
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Sekil-19

OR kapisindan ¢ikis aldik. Burada dikkatinizi ¢cekmek istedigim bir husus daha var. karmagik
devrelerde bazen Pin'lerin kapilarin yonlerinin size verildigi sekilde olmasi devreyi daha karmasik
yapabilir. Kablolama kolaylig1 agisindan bu devre elemanlarinin yonlerini degistirebilmekteyiz.
Devre elemanin tizerine gelip tiklayin ve solda Facing yazan yerden yonleri degistirin kendinize

gore. ( Sekil-20)
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Sekil-20

Son olarak ¢ikis Pin'ini yerlestirip teorik olarak devreyi bitiyoruz. Ama bu bizim i¢in yeterli
degildir. Devrenin anlagilir olmasi i¢in isimlendirmelerin yapilmasi gerekmektedir. ( Sekil-21)
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Sekil-21

Isimlendirmelerimizi yapiyoruz. Isimlendirme islemini de iist satirdaki “A” simgesinden
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Sekil-22

Oncelikle alt devresi yapilacak olan devreyi segiyoruz. Project'den add circuit ya da sol taraftan
yesil art1 simgesi bastyoruz. ( Sekil-23)
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Sekil-23

Ve gelen kiiciik kutucuga alt devre ismini girip “OK’”'a bastyoruz. ( Sekil-24 )
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Dikkat edildigi iizere sol tarafta main'in altinda alt devreye verdigimiz isim goziikmektedir. Main'e
gelip, secip alanda konumlandirip alt devreyi yerlestirdik. Ayni sekilde birden fazla blogu bu sekilde

konumlandirabiliriz. ( Sekil-25)
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Sekil-25

Alt devremizinde diger normal devre gibi 2 girisi ve bir ¢ikisi vardir. Pinlerle giris ve ¢ikislar
konumlandiralim. ( Sekil-26 )
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~ Sekil-26

Simdi birazda tiste menii i¢eriklerine bakalim:

File->New = Bilindigi lizere yeni proje agmamizi saglar.
File->Open = Onceden hazirlanan bir projeyi agmak i¢in kullanilir.
File->Open Recent = En son agilan projeleri gosterir.

File->Close = Projeyi kapatmamizi saglar.

File->Save = Proje kaydetmeyi saglar.

File->Save As = Projeyi farkli kaydetmemizi saglar.

File->Export Image = Projenin resim ¢ikt1 seklinde alinmasini saglar.
File->Print = Projeyi yazdirir.

File->Exit = Projeden ¢ikmay1 saglar.

( Sekil-27)

Neslihan B. COLAK
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Edit Project Simulate Window Help

I MNew Ctrl+N
Open... Ctrl+0
Open Recent

D

Close Ctrl+ Shift- W L
. B L UMORALTDEMVRESE
Save As.., Ctrl+Shift+5 Lo Lo L]
Export mage.. R () e B o SRR
Print... Ctrl+P Lo L p— e ]

L4
S - m Myard o o ]
Preferences... L p— LA
Exit Ctrl+Q ::::::Y':F:: o
leormlmml ......... . . C e e e e e e e e e e e e e e e e e e ]
(Circuit Name xorAltDevresi _File -> New . . . . = Bilindigi iizere yeni proje agmamuzi saglar.. . . . . . . . . . .. .. .|
Shared Label “File -> Open - - - * = Onceden hazrladigimiz bir projemizi agmamizi saglar, - - -~~~ - -
Shared Label Fa... |Fast " File -> Open Recent = Son kullandigimiz projeleri gésterir ve agmamlzuaglar.: S
Shared Label Font |SansSerif Plain 12 “File -> Close - - - - = Projeyi kapatmamizi saglar. - - o ]
"Filé->Save ' ' ' ' =Projemizi kaydetmemizisaglar. =~~~ 0
. File -> Save As. . . = Projemizi farkh kaydetmemizisaglar.. . . . . . . . . .. . . .. .|
File -> Export Image = Projeriziri PNG, GIF, JPEG sekliride fesim giktisiverir.. ~ © ° ° ° © ° "]
File -> Print . . . . = Malumunuz yazdirma. |.5Iem| yapar ....................
" File -> Exit- - - - - 'Qlkl;yapar o e

Edit->Undo Move Selection

Edit->Cut
Edit->Copy
Edit->Paste
Edit->Select All
( Sekil-28 )
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Sekil-27

Yapilan adimin bir dncesine gidilmesini saglar.
Kesme yapar.

= Kopyalama yapar.

= Yapistirma yapar.

= Tamamini secer.
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File Project Simulate Window Help

Undo Move Selection Ctrl+Z

Cut

Copy
Paste

Delete
Duplicate
Select All

Raise Selection
Lower Selection
Raise To Top

Lower To Bottom

Add Vertex

Remove Vertex

Cirl+X
Ctrl+C
Ctrl+V

Delete
Ctrl+D
Ctrl+A

Ctrl+Up
Ctrl+Down
Ctrl+Shift+Up
Ctrl+Shift+ Down

I
Shared Label Font |SansSerif Plain 12

- XORALTDEVRESI - . -

. .Edit-» Undo Move Selection = Yapilan adimdan bir 6neekine gétiiriir. . . . . |
Edit->Cut - - - - - - - - -
. Edit*Copy = 0
. .Edit-» Paste . . . . . . . .
| Edit-> SelectAll -~ ©

= Kesme yapar.- - - - - - - -

= Kopyalama yapar. =~ [ ]
=Yapistirma yapar.. . . . . . . . .. .
=Tamaminiséger. - 000

Project->Add Circuit
Project->Load Library

Sekil-28

= Alt devre yapmak i¢in kullanilir.

dahil etmek i¢in kullanilir.

Project->Analyze Circuit

vs i¢in kullanilir. ( Sekil-29 )

Neslihan B. COLAK

= Daha once alt devre haline getirilmis devreleri bagka devreler i¢ine

= Devrenin analiz edilmesi; dogruluk tablolari, I/O goriintiilenmesi ...
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IFlIe Edit |Plo Simulate Window Help

* .[J Add Circuit...

D & | Load Library
+ 1t 1 Unload Libraries...
J:."UE”;ﬂ;E Move Circuit Up
..... ﬁ X0 Mowe Circuit Down
G- L Wir Set As Main Circuit
- fy Gat L
- | Ple Remove Circuit
[l [ Arit Revert To Default Appearance
- | Me
(e [ Inp| View Toolbox
G- Bag View Simulation Tree
Edit Circuit Layout
— Edit Circuit Appearance
Circuit MNam
Shared Lab Analyze Circuit
Shared Lab Get Circuit Statistics
Shared Lab
Options..

. Project -> Analyze Circuit = Bu kisimda devreleri analiz etmemizde dngruluk

XOR ALTDEVWRESE -

- Project -> Add Circuit. .= Daha.6nce de bahsettik alt devre yapiminda kullanihr.

" Project > Load Library = Bu kisim altinda Logisim Library segenegi vardir. Bu birim -
_ ile ait devre yapip kutuphaneye dahil ettlglmlzl devreleri ba;ka devreleri yapmak

- igin kullamabilir. :

- tablolarinin- garuntulenmesi girig [ ik gnruntulenmeslnde haﬂtalamalarda

" formiile etmede yardimei olacaktir.’

Sekil-29

Analyze Circuit segenegi secildikten sonra ekran goriintiisii: ( Sekil-30)

File Edit Project Simulate Window Help

| Inputs | Outputs |; Table || Expression | Minimized

Analyze Circuit segenegi segtikten sonra bu yapi karsimiza
cikmaktachr. Input'da girigleri, Output'da cikaslan,
Table'de dogruluk tablosunu gérmemiz miimkiindir.

Simulate->Simulate Enabled
Simulate->Reset Simulation

Neslihan B. COLAK

Sekil-30

Simiilasyon isleminin hali hazirda ¢caligsmasidir.
Simiilasyonu basa alir.



= Adim adim simiile eder.

Clock pulse'nin tek tek elle verilmesidir.

Clock pulse'nin frekansa gore siirekli verilmesidir.
Clock pulse'i i¢in frekans ayarlanmasidir. ( Sekil-31)

Simulate->Reset Simulation
Simulate->Tick Once
Simulate->Tick Enabled
Simulate->Tick Frequency

File Edit Project ISimulate Window Help

I & A | [ ¥ Simulation Enabled Ctri+E

Dﬁ |El Reset Simulation Ctrl+R -
+ 1t *® Step Simulation Ctrl+I o
----- a woraltDevre Go In To State L4 oo o
N o SR
G- | Gates Tick Once Ctrl+T o
[l [ Plexers Ticks Enabled Ctrl+K SR
[+ | Arithmetic . S
-}y Memory Tick Frequency L o1 o
- InputfOutpu | = & oory
[+~ || Base lorpMz= |

Circuit: xorAltDevresi
Circuit Name

Shared Label
Shared Label Fa... |[East
Shared Label Font |SansSerif Plain 12

xorAltDevresi

. . Simulation -» Step . .. . .= Adim adim simiile eder. . . . . .

133%

Window->Minimize
Window->Maximize
Window->Close

Window->Combinational Analysis

Neslihan B. COLAK

© Simulation -
. Simulation -
- Simulation -

>Tick Once - - = Clock pulse’'min tek tek elle verilmesidir. { ctrl+t )
> Tick Enabled . = Clock pulse’nin frekansa gére siirekli verilmesidir.. = . = |
>Tick Frequency = Clock pulse'i igin frekans ayarlanmasidir.- - - - - - - - - -

Sekil-31

= Pencereyi kii¢iiltme
= Pencereyi biiylitme
= Pencereyi kapatma

= Yukarida analiz kisminda anlatilmistir. ( Sekil-32 )
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|| File Edit Project Simulate I'W'lndmv Help

lax]alm e
I EEY ]!

+ 1t I X
, Untitled®

B miin

ﬁ xorAltDevresi
- L Wiring

. Gates

. Plexers

. Arithmetic

. Memory

Minimize Ctrl+M
Maximize _
Close Cerl+W |

Combinational Analysis

Preferences KORALT DEVRES|

SP_icyapisi

nbc

. Input/Qutput

. Base

oy O e O (O o O oy Oy O |
[ N E8 BT R
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Circuit: xorAltDevresi

Circuit Name xorAltDevresi

Shared Label

Shared Label Fa... [East

Shared Label Font |SansSerif Plain 12

Untitled

@ ooy

Y B
: Wlndnw malumunuz kl penl:ere yapm |Ie ||gi||d|r
“Window-> Minimize= Pencereyi kiigliltme
- Window-> Maximize= Pencerayi biyiitme.
' Window-> Close= Pencereyi kapatma =~
. Window-> Combinational Analysis = Analiz kisminda anlatlldlgl glbl devrenin analizinde
i kullanlllr I,{'O dngruluk tablnlarl, harltalar : I

Sekil-32

Help mentisii yardim igeriklidir. ( Sekil-33)

D> togiieroDeres it =

|| File Edit Project Simulate Window

He o

+ 1t 1 X

Ii.A|l®[>°D Tutorial

, Untitled*

----- G main

----- ﬁ xorAltDevresi
- L Wiring

. Gates

- | Plexers

- |, Arithmetic

. Memory

. Input/Output

- . base

[rrm T e O s O e OO e O e B
—_——— e e e

Circuit: xorAltDevresi

| Circuit Mame xor AltDevresi

\|shared Label

Shared Label Fa. .. [East

Shared Label Font |SansSerif Plain 12
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User's Guide

Library Reference

About...

- XOR-ALT DEYRESI

@ ooy

Blldlgl lizere Helpr Menusu r.le I:rlze kuilanlm knnusunda ;eglth o
~ " yardimlar saglamaktadlr o

Sekil-32



